środa, 13 lipca 2016

[SNMP] Instalacja usługi SNMP w systemie Windows oraz Linux

Simple Network Management Protocol – rodzina protokołów sieciowych wykorzystywanych do zarządzania urządzeniami takimi jak routery, przełączniki, komputery czy centrale telefoniczne za pośrednictwem sieci IP. Do transmisji wiadomości SNMP wykorzystywany jest głównie protokół UDP: standardowo port 161 wykorzystywany jest do wysyłania i odbierania żądań, natomiast port 162 wykorzystywany jest do przechwytywania sygnałów trap od urządzeń. Możliwe jest także wykorzystanie innych protokołów do przekazywania żądań, na przykład TCP[1].

Istnieją trzy wersje protokołu:
- SNMPv1 – pierwsza wersja, która została opublikowana w 1988 roku w dokumencie RFC 1067 (z późniejszymi zmianami w RFC 1098 oraz RFC 1157). W tej wersji protokołu bezpieczeństwo oparte jest na tak zwanych communities, które są pewnego rodzaju nieszyfrowanymi hasłami umożliwiającymi zarządzanie urządzeniem.
- SNMPv2 – eksperymentalna wersja protokołu, określana także SNMPv2c, opisana w dokumencie RFC 1901
- SNMPv3 – wspierająca uwierzytelnianie oraz szyfrowaną komunikację

Każdy komunikat dotyczy określonej zmiennej, tzw. OID (ang. Object IDentifier). Dla przykładu zmienna OID o nazwie sysUpTime (czas pracy urządzenia od ostatniego włączenia) ma postać 1.3.6.1.2.1.1.3.0, co odpowiada jej adresowi w drzewie MIB. (źródło: Wikipedia.com)

Instalacja usługi SNMP w systemie Windows XP
Przechodzimy do panelu sterowania następnie wybieramy "Dodaj usuń Programy" następnie przechodzimy do menu "Dodaj usuń składniki systemu Windows". W Kreatorze składników szukamy pozycji "Narzędzia zarządzania i monitorowania" i klikająć dwukrotnie zaznaczamy "Protokół SNMP"

Rysunek 1 - Windows XP Instalaja SNMP


Instalacja usługi SNMP w systemie Windows 7/8/10
W nowszych systemach podobnie wchodzimy w "Panel Sterowania", następnie "Włącz lub wyłącz Funkcje systemu Windows" i zaznaczamy "Protokół SNMP"


Rysunek 2 - Windows 7/8/10 Instalacja SNMP

Konfiguracja usługi SNMP w systemach Windows
Po zainstalowaniu serwisu musimy go skonfigurować. W tym celu przechodzimy do "Narzędzi administratora" znajdujących się w "Panelu sterowania" i uruchamiamy narzędzie "Usługi" Z listy usług odszukujemy "SNMP Service". Upewniamy się czy nasza usługa jest uruchamiana automatycznie z systemem.

Rysunek 3 - Okno konfiguracji SNMP

Kolejnym krokiem jest konfiguracja naszego Agenta. Czyli informacje które będą prrzysyłane o naszym komputerze oraz jego nazwa i lokalizacja.

Rytsunek 4 - Okno konfiguracji Agenta

Pragnę zauważyć że warto sobie lokalizację podzielić w jakiś hierarchiczny sposób co ułatwi nam grupowanie komputerów i urządzeń w naszym programie do monitoringu. Ostatnim krokiem jest nadanie praw dostępu oraz "społeczności" którą można też traktować jak hasło dla naszego serwera monitoringu.

Rysunek 5 - Konfiguracja zabezpieczeń SNMP

Dla większego bezpieczeństwa można ustawić akceptację dla hosta serwera oraz zabezpieczenia typu TRAP tzw. "pułapka".

Instalacja usługi SNMP w systemie Linux Debian
W systemie Debian cała instalacja sprowadza się do wydania kilku prostych komend.

sudo apt-get update 
sudo apt-get install snmp snmpd snmp-mibs-downloader

Konfiguracja usługi w systemie Linux Debian
Konfiguracja sprowadza się do edycji dwóch plików i restarcie serwisu.

nano /etc/snmp/snmpd.conf  

Edytujemy/dodajemy poniższe linie:
agentAddress  udp:161
rocommunity nazwa_społeczności  default    -V systemonly
sysLocation    lokalizacja_komputera
sysContact     nazwa_komputera
view   systemonly  included   .1.3.6.1.2.1.2

W pliku snmpd.conf ustawiamy protokół i port dostępu, nazwe społeczności, nazwę komputera, lokalizację oraz zasoby które mają być udostępnione przez protokół SNMP. W celu zapoznania sie z zmiennymi OID polecam witrynę: http://www.alvestrand.no/objectid/1.3.6.1.2.1.html

nano /etc/snmp/snmp.conf       
.
W tym pliku tylko należy zakomentować linijkę "mibs:" znakiem "#". Po zapisaniu plików konfiguracyjnych resetujemy nasz servis komendą

service snmp restart

Przykład dodawania urządzenia lub komputera do serwera monitoringu SNMP.

Rysunek 6 - Przykład dodawania urządzenia lub komputera do serwera SNMP

Po dodaniu nowego sprzętu należy odczekać trochę czasu aż nasze dane statystyczne zostaną zebrane w naszym serwerze. Po jakimś czasie ukażą nam się ładne kolorowe grafy oraz wykresy. Dzięki temu będziemy mieli monitoring i wgląd nad wszystkimi urządzeniami w jednym miejscu.

Rysunek 7 - Monitoring na przykładzie Observium

Mam nadzieję że artykuł był zrozumiały. W jednym z następnych zajmę się instalacją serwera który będzie gromadził dane za pomocą protokołu SNMP.

wtorek, 12 lipca 2016

[Apache2] [warn] The Alias directive in /etc/phpmyadmin/apache.conf

Jak usunąć problemy w Apache2 związane z Aliasami. Po aktualizacji pakietów i restarcie usługi Apache pojawiły mi się poniższe błędy. Z racji że wcześniej nie miałem czasu się tym zająć dzisiaj się zabrałem za rozwiązanie tych błędów.

 Rysunek 1 - Urywek komunikatu błędu.

Błąd 1
[....] Reloading web server config: apache2[Tue Jul 12 19:06:11 2016] [warn] The Alias directive in /etc/phpmyadmin/apache.conf at line 3 will probably never match because it overlaps an earlier Alias.

apache2: Could not reliably determine the server's fully qualified domain name, using 185.49.14.15 for ServerName

Wyjaśnienie: Pierwszy błąd mówi o tym że nie udało się wiarygodnie ustalić pełnej nazwy domeny serwera i zostanie użyty adres IP dla parametu ServerName.

Rozwiązanie: Należy dokonać edycji pliku /etc/phpmyadmin/apache.conf i nadać nazwę naszego serwera. W tym celu używamy gotowych komend.

nano /etc/phpmyadmin/apache.conf

# plik apache.conf (dodajemy poniższą linijke)
ServerName GamingCenter.pl


Błąd 2
[....] Restarting web server: apache2[Tue Jul 12 19:09:55 2016] [warn] The Alias directive in /etc/phpmyadmin/apache.conf at line 4 will probably never match because it overlaps an earlier Alias.

... waiting [Tue Jul 12 19:09:56 2016] [warn] The Alias directive in /etc/phpmyadmin/apache.conf at line 4 will probably never match because it overlaps an earlier Alias.


Wyjaśnienie: Drugi błąd mówi o tym że dyrektywa aliasu /etc/phpmyadmin/apache.conf na linii 4 nie będzie prawdopodobnie nigdy pasować, ponieważ pokrywa się z wcześniejszym aliasem.

Rozwiązanie:
Należy dokonać edycji pliku /etc/apache2/apache2.conf i zakomentować linię "Include /etc/phpmyadmin/apache.conf" znakiem "#" jak na Rys. 2.

Rysunek 2 - Plik /etc/apache2/apache2.conf 

Teraz wystarczy zrestartować serwer Apache 2 i nie powinniśmy więcej widzieć błędów. Do tego celu używamy poniższej komendy.

service apache2 restart


środa, 29 czerwca 2016

[PLEX] Missing MFPlat.DLL

Dzisiaj postanowiłem zaktualizować PLEXA do wersji Plex-Media-Server-0.9.1700.2108. Niestety proces zakończył się błędem podczas próby uruchomienia. 

"The program cant start because MFPlat.DLL is missin from your computer. Try to reinstall the program to fix the problem"

Jest jednak rozwiązanie, należy w systemie zainstalować pakiet MediaPlayback Features. Uruchamiamy wiersz poleceń i wywołujemy poniższą komendę:

dism /online /enable-feature /featurename:MediaPlayback

Rysunek 1 - Wiersz poleceń

Po zainstalowaniu pakietu i ponownym uruchomieniu PLEX powinien już wpełni działać. Może się zdarzyć że będzie wymagane ponowne zainstalowanie PLEXA.

wtorek, 21 czerwca 2016

[Ubiquity] Zmiana portów HTTP i HTTPS

Po co zmieniać te porty ? Z kilku przyczyn, czyli po pierwsze bezpieczeństwa. Jeżeli ktoś się nie zna nie będzie próbował korzystać z tych portów aby się włamać/zalogować. Drugim powodem może być tak jak u mnie że posiadam serwisy wystawione na świat pod portem 80 i 443. Nie chciał bym aby pod domeną widniała strona logowania do routera tylko moja witryna.

Wystarczy wykonać proste dwie komendy oraz je zatwierdzić:

set service gui http-port 8080
set service gui https-port 8443
commit

 Teraz nasz router będzie nasłuchiwał na nowych portach HTTP: 8080 oraz HTTPS: 8443

Dodatkowym zabezpieczeniem dostępu do routera jest zmiana domyślnego portu SSH ale to już będzie w innym wpisie lub sami się domyślcie jak to zmienić.

[Ubiquity] EdgeMax Firmware Upgrade via CLI

W tym wpisie pokażę wam jak szybko zaktualizować wasz router do najnowszej wersji oprogramowania z linii poleceń. Według mnie jest to najszybsza i najwygodniejsza metoda aktualizacji. Jako pierwszy krok musimy wejść na stronę Ubiquity i skopiować link do pobierania.

Rysunek 1 - Strona pobierania

W moim przypadku jest to zakreślony link który kopiujemy do schowka. Logujemy się do naszego routera przez SSH za pomocą klienta (np. Putty lub Xshell). 

Lista przydatnych komend:

 Rysunek 2 - show version - pokazuje aktualną wersję firmware


Rysunek 3 - add system image *adres_url* - dodajemy adres naszego pliku z firmware


Rysunek 4 - show system image - pokazuje wersje systemów które posiadamy 

Teraz musimy wykonać restart routera aby nasz aktualnie uruchomiony obraz został zamieniony nowym. Po ponownym rozruchu należy sprawdzić aktualnie używaną wersję i usunąć starą.

 Rysunek 5 - Sprawdzamy wersję firmware po restarcie routera

 Rysunek 6 - Kasujemy stary obraz systemu

Jeżeli nie jesteśmy pewni nowej aktualizacji możemy zostawić stary obraz aby wrazie problemów do niego powrócić. Wystarczy użyć komendy "set system image default-boot"

Rysunek 7 - Przełączanie pomiędzy dostępnymi wersjami firmware

Mam nadzieję że ten wpis pomógł Ci uporać się z aktualizacją firmware. Dla mnie jest to najwygodniejszy sposób aktualizacji gdyż z poziomu GUI miewałem problemy.

niedziela, 5 czerwca 2016

IPMI - Jak zmniejszyć próg działania wentylatorów

Każdy lubi cichą pracę komputera czy serwera. Mój serwer posiada płytę SuperMicro X10SLL+-F z gniazdami 4-pin PWM dla lepszego zarządzania prędkością wentylatorów. Wymieniłem zwykłe 3-pin na 4-pin PWM wentylatory marki GELID. Na prawdę są ciche i wydajne. Wszystko było pięknie aż do uruchomienia serwera. Okazało się że ich zbyt niskie obroty generowały ostrzeżenia w EventLogu. Powodowało to że wentylatory rozpędzały się do maximum i zwalniały kiedy znowu przekroczyły najniższy próg rozpędzały się na maximum. Z pomocą przyszło narzędzie IPMITool. Do tego wystarczy nam jakikolwiek system Linux w tej samej sieci co nasz serwer z IPMI.

Rysunek 1 - EventLog


Dzięki narzędziu IPMITool w szybki sposób zmienimy te wartości. Zacznijmy od zainstalowania narzędzia w środowisku Linux.

sudo apt-get install ipmitool

Kolejnym krokiem jest użycie odpowiedniej komendy.
Rysunek 2 - Użycie narzędzia IPMITool

ipmitool -I lan -U ADMIN -H 10.10.1.202 sensor thresh FAN1 lower 150 225 300

Wyjaśnienie parametrów komend:
ADMIN - konto użytkownika IPMI
10.10.1.202 - adres IP urządzenia IPMI
FAN1 - wentylator któremu zmieniamy parametry FAN (FANA, FAN1, FAN2, FAN3, FAN4)
150 - wartość nienaprawialna
225 - wartość krytyczna
300 - wartość nie krytyczna

Zmiany powinny być od razu odczuwalne i widoczne w panelu www IPMI. Czasami jednak zmiany mogą dać efekt po ponownym uruchomieniu maszyny. Dlatego dla własnego spokoju lepiej wykonać ponowny rozruch serwera.
Rysunek 3 - IPMI via WWW

Mam nadzieję że ten artykuł wam pomógł.

czwartek, 2 czerwca 2016

[VMWARE] ESXI błąd startu usługi SNMPD

SNMPD to usługa dzięki której możemy monitorować zasoby naszego serwera. Czasem się zdarza że przy próbie uruchomienia tej usługi pokazuje nam się poniższy błąd.

Call "HostServiceSystem.Start" for object "serviceSystem-125" on vCenter Server "<vCenter_server_fqdn>" failed.

Błąd pojawia się ponieważ nasz plik: snmp.xml najprawdopodobniej jest uszkodzony.

Aby rozwiązać problem należy zalogować się do serwera przez SSH i przejść do folderu z naszym plikiem.

cd /etc/vmware

Warto wykonać sobie kopie zapasową pliku poniższą komendą:

cp snmp.xml snmp.xml.bkup


Rysunek 1 - Połączenie SSH z naszym serwerem.

Otwieramy nasz plik: snmp.xml dowolnym edytorem tekstowym np. nano lub vi i wklejamy do niego poniższą zawartość:


<?xml version="1.0" encoding="ISO-8859-1"?>

<config>

<snmpSettings>

<enable>true</enable>
<port>161</port>
<syscontact></syscontact>
<syslocation></syslocation>
<EnvEventSource>indications</EnvEventSource>
<communities>public</communities>
<loglevel>info</loglevel>
<authProtocol></authProtocol>
<privProtocol></privProtocol>
</snmpSettings>
</config>


Zapisujemy plik i za pomocą klienta vSphere Client uruchamiamy serwis SNMPD.

Configuration > Security Profile > Properties > SNMPD service > Options > Start

Rysunek 2 - Monitorowany serwer ESXI w Observium (SNMPD)